Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RailingHandrailType Struct Reference

Represents a Handrail element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_Guid owner
 GUID of the Railing Segment element owning this Handrail.
 
API_Guid symbID
 The identifier of the symbol of this element.
 
bool visible
 True, if the Handrail is visible.
 
bool doubleHandrail
 True, if the Handrail is relative.
 
double horizontalOffset
 The horizontal offset of the Handrail from the Segment.
 
double height
 The height of the Handrail element.
 

Detailed Description

Represents a Handrail element.