Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RailingInnerPostType Struct Reference

Represents an Inner Post element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_Guid owner
 GUID of the Railing Pattern element owning this Inner Post.
 
API_Guid symbID
 The identifier of the symbol of this element.
 
double doublePostOffset
 Offset of the Inner Posts from the pattern.
 
API_RailingVerticalPosData verticalPosition
 Vertical alignment of this element.
 
API_RailingHorizontalPosData horizontalPosition
 Horizontal alignment of this element.
 
short postNum
 The amount of posts within this element (maximum of 2).
 

Detailed Description

Represents an Inner Post element.