Archicad 28 C++ API
|
Represents the model view options of Railings made with Railing Tool. The entire structure is Archicad only. More...
#include <APIdefs_ViewSettings.hpp>
Public Attributes | |
char | railing3DDetailLevel |
Detail level of railings in 3D display. | |
bool | railing2DDisplayCompPosts |
Posts are visible in Floor Plan Visualization. | |
bool | railing2DDisplayCompTopRail |
Top rails are visible in Floor Plan Visualization. | |
bool | railing2DDisplayCompHandrails |
Handrails are visible in Floor Plan Visualization. | |
bool | railing2DDisplayCompRails |
Rails are visible in Floor Plan Visualization. | |
bool | railing2DDisplayCompInnerPosts |
Inner posts are visible in Floor Plan Visualization. | |
bool | railing2DDisplayCompBalusters |
Balusters are visible in Floor Plan Visualization. | |
bool | railing2DDisplayCompPanels |
Panels are visible in Floor Plan Visualization. | |
API_AttributeIndex | railingSchemeSurfaceIndex |
Index of the Surface attribute to use in Schematic 3D Display Detail. | |
API_AttributeIndex | railingSchemeCutLineIndex |
Index of the Line attribute to use in Schematic 3D Display Detail as Cut Line. | |
short | railingSchemeCutLinePenIndex |
Index of the Pen in the current Pen Table to use in Schematic 3D Display Detail as the Cut Line Pen. | |
API_AttributeIndex | railingSchemeUncutLineIndex |
Index of the Line attribute to use in Schematic 3D Display Detail as Uncut Line. | |
short | railingSchemeUncutLinePenIndex |
Index of the Pen in the current Pen Table to use in Schematic 3D Display Detail as the Uncut Line Pen. | |
Represents the model view options of Railings made with Railing Tool. The entire structure is Archicad only.