Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RailingPanelType Struct Reference

Represents a Railing Panel element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_Guid owner
 GUID of the Railing Segment element owning this Railing Panel.
 
API_Guid symbID
 The identifier of the symbol of this element.
 
bool visible
 True, if the Railing Panel is visible.
 
API_RailingFrameData frame
 Describes the boundaries of the Railing Panel.
 

Detailed Description

Represents a Railing Panel element.