Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RailingRailConnectionType Struct Reference

Represents a connection between two Rail/Handrail/Toprail elements. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_Guid owner
 GUID of the Railing Node element owning this Rail Connection.
 
API_Guid symbID
 The identifier of the symbol of this element.
 
API_RailBaseBaseConnectionID baseConnection
 Connection type between two Rail bases: |APIBB_Horizontal|Connection type is horizontal.| |APIBB_Tangential|Connection type is tangential.|.
 
API_RailConnectionTypeID type
 Connection type: |APICT_NoRailConnection|Disconnected.| |APICT_GooseneckRailConnection|Gooseneck connection.| |APICT_DirectRailConnection|Direct connection.|.
 
double railEndOffset
 Offset from the end of the rail.
 
double railEndFillet
 Fillet at the end of the rail.
 
double firstExtrusionLength
 Length of the first extrusion.
 
double secondExtrusionLength
 Length of the second extrusion.
 
double horizontalFillet
 Horizontal filleting.
 
double gooseneckFillet
 Gooseneck filleting.
 
double gooseneckOffset
 Gooseneck offset.
 
double verticalBottomFillet
 Vertical bottom filleting.
 
double directFillet
 Direct filleting.
 

Detailed Description

Represents a connection between two Rail/Handrail/Toprail elements.

Member Data Documentation

◆ baseConnection

API_RailingRailConnectionType::baseConnection

Connection type between two Rail bases: |APIBB_Horizontal|Connection type is horizontal.| |APIBB_Tangential|Connection type is tangential.|.

◆ type

API_RailingRailConnectionType::type

Connection type: |APICT_NoRailConnection|Disconnected.| |APICT_GooseneckRailConnection|Gooseneck connection.| |APICT_DirectRailConnection|Direct connection.|.