Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RailingRailType Struct Reference

Represents a Rail element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_Guid owner
 GUID of the Railing Segment element owning this Rail.
 
API_Guid symbID
 The identifier of the symbol of this element.
 
bool visible
 True, if the Rail is visible.
 
bool relative
 True, if the Rail is relative.
 
double horizontalOffset
 The horizontal offset of the Rail from the Segment.
 
double height
 The height of the Rail element.
 

Detailed Description

Represents a Rail element.