Archicad 28 C++ API
|
Rubber line definition. More...
#include <APIdefs_Interface.h>
Public Attributes | ||
API_Coord3D | origC | |
Coordinate of the center point. | ||
bool | radii | |
Draw radii as well. | ||
char | filler [7] | |
Reserved for later use. | ||
API_RubberLineThickness | lineThick | |
The thickness of the line, can be APIRubberLine_Simple or APIRubberLine_Double . | ||
API_RubberArcTypeID | arcType | |
The arc is defined with arc2D (used only in 2D) or arc3D structure (APIRubberArc_OrigoAngles or APIRubberArc_ThreePoint ). | ||
union { | ||
struct { | ||
double r | ||
Radius (or 'a' if ellipse) | ||
double angle | ||
This value should be 0.0 in circle case or the angle of the 'a' axis of the ellipse. | ||
double ratio | ||
This value should be 1.0 in circle case or 'a/b' of the ellipse. | ||
double begAng | ||
Beginning angle of the arc. | ||
double endAng | ||
Ending angle of the arc. | ||
} arc2D | ||
struct { | ||
API_Coord3D begC | ||
Beginning point of the circular arc (defined by it's origo and two points - for 3D) | ||
API_Coord3D endC | ||
End point of the circular arc (defined by it's origo and two points - for 3D) | ||
bool sign | ||
The angle of the circular arc (defined by it's origo and two points - for 3D). More... | ||
char filler [7] | ||
Reserved for later use. | ||
} arc3D | ||
}; | ||
Rubber line definition.
API_RubberArcType
.