Archicad 28 C++ API
Loading...
Searching...
No Matches
API_SavePars_Ifc Struct Reference

Parameters to save the current project as an Ifc file. More...

#include <APIdefs_Automate.h>

Public Attributes

API_IfcTypeID subType
 Defines whether to save IFC or IFC ZIP format.
 
API_IFCTranslatorIdentifier translatorIdentifier
 Define the translator identifier, for IFC save.
 
API_ElementsToIfcExportID elementsToIfcExport
 Define type of elements which will be exported.
 
const GS::Array< API_Guid > * elementsSet
 Define the elements set (which elements will be saved into the file) or leave nullptr to save all elements.
 
bool includeBoundingBoxGeometry
 Defines whether to calculate and save the corresponding IfcBoundingBox.
 

Detailed Description

Parameters to save the current project as an Ifc file.

Since
Archicad 26
Remarks
You'll have to pass this structure to the ACAPI_ProjectOperation_Save function.