Archicad 27 C++ API
Loading...
Searching...
No Matches
API_SectElemType Struct Reference

Describes an element in the section window. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_ElemType parentType
 Parent elem type.
 
API_Guid parentGuid
 Parent elem GUID.
 
API_Guid ownerGuid
 GUID of owner curtain wall it the parent is a curtain wall subelem (frame, panel, junction or accessory). APINULLGuid in all other cases.
 

Detailed Description

Describes an element in the section window.

Since
Archicad 26
Remarks
This structure represents elements in the section window, which originally were created in the 2D or 3D window, and are visible in the current section window. From version 26 the type of the parentID member was changed into API_ElemType.