Archicad 28 C++ API
Loading...
Searching...
No Matches
API_ShapePrimsParams Struct Reference

Shape primitive parameters. More...

#include <APIdefs_Elements.h>

Public Attributes

bool dontClip
 Pass false to turn off clippings when exploding a drawing.
 
bool allStories
 Pass false to use the drawing only on the current story.
 
Geometry::Polygon2D * polygon
 Set a pointer to Geometry::Polygon2D to set that as a clipping polygon for the drawing.
 

Detailed Description

Shape primitive parameters.

Remarks
Use the ACAPI_DrawingPrimitive_ShapePrimsExt function to virtually draw the shape of an element.