Archicad 27 C++ API
Loading...
Searching...
No Matches
API_SideStairStructData Struct Reference

Represents the data of a side supported Stair Structure element. More...

#include <APIdefs_Elements.h>

Public Attributes

double width
 The width of the Stair Structure element.
 
double heightAboveTread
 The height of the Stair Structure above its related Tread.
 
API_StairStructHeightMeasureID heightMeasure
 The way of measuring of height above treads: |APIHM_Perpendicular|Perpendicular calculation.| |APIHM_Vertical|Straight vertical calculation.|.
 

Detailed Description

Represents the data of a side supported Stair Structure element.

Member Data Documentation

◆ heightMeasure

API_SideStairStructData::heightMeasure

The way of measuring of height above treads: |APIHM_Perpendicular|Perpendicular calculation.| |APIHM_Vertical|Straight vertical calculation.|.