Archicad 27 C++ API
Loading...
Searching...
No Matches
API_SlabQuantity Struct Reference

Describes the different calculated values for slabs. More...

#include <APIdefs_Elements.h>

Public Attributes

double bottomSurface
 bottom surface of the slab
 
double topSurface
 top surface of the slab
 
double edgeSurface
 surface of the edges of the slab
 
double bottomSurface_cond
 conditional bottom surface of the slab
 
double topSurface_cond
 conditional top surface of the slab
 
double volume
 volume of the slab
 
double volume_cond
 conditional volume of the slab
 
double perimeter
 perimeter of the slab
 
double holesSurf
 total area of holes in the slab
 
double holesPrm
 total perimeter of holes in the slab
 
double grossBotSurf
 Gross surface of the slab bottom.
 
double grossTopSurf
 Gross surface of the slab top.
 
double grossEdgeSurf
 Gross surface of the slab edges.
 
double grossVolume
 Gross volume of the slab.
 
double grossBotSurfWithHoles
 Gross surface of the slab bottom with holes.
 
double grossTopSurfWithHoles
 Gross surface of the slab top with holes.
 
double grossEdgeSurfWithHoles
 Gross surface of the slab edges with holes.
 
double grossVolumeWithHoles
 Gross volume of the slab with holes.
 

Detailed Description

Describes the different calculated values for slabs.

Remarks
See also the slab parameters for listing in Appendix A of the GDL Reference manual.