Archicad 27 C++ API
Loading...
Searching...
No Matches
API_SplineDir Struct Reference

Describes the control handles for Bezier-splines. More...

#include <APIdefs_Elements.h>

Public Attributes

double lenPrev
 Bezier direction length previous.
 
double lenNext
 Bezier direction length next.
 
double dirAng
 Bezier direction angle.
 

Detailed Description

Describes the control handles for Bezier-splines.

Remarks
The picture below illustrates the meaning of these fields.
Spline direction