Archicad 27 C++ API
Loading...
Searching...
No Matches
API_StairBoundaryEdgeData Struct Reference

Stores data of a stair boundary edge. More...

#include <APIdefs_Elements.h>

Public Attributes

API_StairPolyTypeID type
 The type of the boundary polyline section.
 
API_StairPolyGeometryTypeID geometryType
 The geometry type of the boundary polyline section.
 
UInt32 subElemId
 The subelement identifier of the boundary polyline section.
 
bool isTop
 The section describes the top of the subelement.
 
bool isBottom
 The section describes the bottom of the subelement.
 
bool isFront
 The section describes the front of the subelement.
 
bool isBack
 The section describes the back of the subelement.
 
UInt32 customId
 Internal identifier.
 
bool visible
 The described subelement is visible.
 

Detailed Description

Stores data of a stair boundary edge.