Archicad 28 C++ API
|
Stores data of a stair boundary vertex. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_StairPolyTypeID | type |
The type of the boundary polyline section. | |
API_StairPolyGeometryTypeID | geometryType |
The geometry type of the boundary polyline section. | |
UInt32 | subElemId |
The subelement identifier of the boundary polyline section. | |
bool | isTop |
The section describes the top of the subelement. | |
bool | isBottom |
The section describes the bottom of the subelement. | |
bool | isFront |
The section describes the front of the subelement. | |
bool | isBack |
The section describes the back of the subelement. | |
UInt32 | customId |
Internal identifier. | |
double | zValue |
Value in the z axis. | |
Stores data of a stair boundary vertex.