Archicad 27 C++ API
Loading...
Searching...
No Matches
API_StairHeadroomData Struct Reference

Description of the Stair Headroom. More...

#include <APIdefs_Elements.h>

Public Attributes

API_HeadroomGenerationModeID headroomMethod
 The type of room generation mode: APIHM_RightAngleToSlope or APIHM_VerticallyToSlope.
 
double headroomHeight
 The height of the headroom.
 
double headroomLeftOffset
 The offset of the headroom from the left side.
 
double headroomRightOffset
 The offset of the headroom from the right side.
 

Detailed Description

Description of the Stair Headroom.