Archicad 27 C++ API
Loading...
Searching...
No Matches
API_StairPolylineEdgeData Struct Reference

Stores data of a stair polyline edge. More...

#include <APIdefs_Elements.h>

Public Attributes

API_StairPolyTypeID type
 The type of the boundary polyline section.
 
API_StairPolyGeometryTypeID geometryType
 The geometry type of the boundary polyline section.
 
UInt32 subElemId
 The subelement identifier of the boundary polyline section.
 
bool isTop
 The section describes the top of the subelement.
 
bool isBottom
 The section describes the bottom of the subelement.
 
bool isFront
 The section describes the front of the subelement.
 
bool isBack
 The section describes the back of the subelement.
 
UInt32 customId
 Internal identifier.
 
API_StairSegmentTypeID segmentType
 Type of the segment described by this edge: |APIST_StepsSegment|Step segment.| |APIST_LandingSegment|Landing segment.| |APIST_DividedLandingSegment|Divided landing segment.|.
 
bool isLocked
 If true, edge is locked.
 

Detailed Description

Stores data of a stair polyline edge.

Member Data Documentation

◆ segmentType

API_StairPolylineEdgeData::segmentType

Type of the segment described by this edge: |APIST_StepsSegment|Step segment.| |APIST_LandingSegment|Landing segment.| |APIST_DividedLandingSegment|Divided landing segment.|.