Archicad 27 C++ API
Loading...
Searching...
No Matches
API_StairQuantity Struct Reference

Calculates values for stairs. More...

#include <APIdefs_Elements.h>

Public Attributes

double area
 The front surface area of the stair.
 
double volume
 Volume of the stair.
 
double height
 Height of the stair.
 
double walklineLength
 Length of the stair's walking line.
 
double gradient
 Inclination angle of the stair.
 
Int32 numOfRisers
 Number of risers in this stair.
 
Int32 numOfTreads
 Number of treads in this stair.
 

Detailed Description

Calculates values for stairs.