Archicad 28 C++ API
|
Represents a Riser element. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_Elem_Head | head |
General element header. | |
API_RiserPositionID | riserPosition |
Riser position: |APIRP_OnTread|Risers are placed on top of the treads.| |APIRP_BehindTread|Risers are behind the treads.|. | |
API_RiserCrossSectID | crossSect |
Riser cross section type: |APIRCS_Simple|Simple, straight risers| |APIRCS_Slanted|Slanted risers.|. | |
double | angle |
Slanting angle of risers, if they are slanted. | |
double | offset |
Riser gap. | |
double | thickness |
Riser thickness. | |
API_Guid | owner |
GUID of the owning stair. | |
API_Guid | libId |
Library part GUID. | |
UInt32 | sequenceNumber |
The number of the step that the riser belongs to. | |
UInt32 | subElemId |
The subelement identifier of the riser. | |
bool | visible |
True, if the object is visible. | |
API_StairPartRoleID | role |
Role of the Stair subelement. | |
Represents a Riser element.
API_StairRiserType::crossSect |
Riser cross section type: |APIRCS_Simple|Simple, straight risers| |APIRCS_Slanted|Slanted risers.|.
API_StairRiserType::riserPosition |
Riser position: |APIRP_OnTread|Risers are placed on top of the treads.| |APIRP_BehindTread|Risers are behind the treads.|.