Represents a the Rules and Standards of a Stair element.
More...
#include <APIdefs_Elements.h>
|
double | riserHeightMinValue |
| Minimum riser height.
|
|
double | riserHeightMaxValue |
| Maximum riser height.
|
|
double | treadDepthMinValue |
| Minimum going length.
|
|
double | treadDepthMaxValue |
| Maximum going length.
|
|
double | ruleMinValue |
| Minimum 2R+G.
|
|
double | ruleMaxValue |
| Maixmum 2R+G.
|
|
double | landingLengthMinValue |
| Minimum automatic landing length.
|
|
double | walkingLineOffsetMinValue |
| Minimum automatic landing offset.
|
|
double | winderTurnOffsetMinValue |
| Minimum winder width.
|
|
double | riserGoingRatioMinValue |
| Minimum riser height/tread length ratio.
|
|
double | riserGoingRatioMaxValue |
| Maximum riser height/tread length ratio.
|
|
double | riserPlusGoingMinValue |
| Minimum riser height + tread length value.
|
|
double | riserPlusGoingMaxValue |
| Maximum riser height + tread length value.
|
|
double | stairPitchMinValue |
| Minimum stair pitch.
|
|
double | stairPitchMaxValue |
| Maximum stair pitch.
|
|
bool | riserHeightMinApplied |
| Minimum riser height set.
|
|
bool | riserHeightMaxApplied |
| Maximum riser height set.
|
|
bool | treadDepthMinApplied |
| Minimum going length set.
|
|
bool | treadDepthMaxApplied |
| Maximum going length set.
|
|
bool | ruleMinApplied |
| Minimum 2R+G set.
|
|
bool | ruleMaxApplied |
| Maixmum 2R+G set.
|
|
bool | landingLengthMinApplied |
| Minimum automatic landing length set.
|
|
bool | walkingLineOffsetMinApplied |
| Minimum automatic landing offset set.
|
|
bool | winderTurnOffsetMinApplied |
| Minimum winder width set.
|
|
bool | riserGoingRatioMinApplied |
| Minimum riser height/tread length ratio set.
|
|
bool | riserGoingRatioMaxApplied |
| Maximum riser height/tread length ratio set.
|
|
bool | riserPlusGoingMinApplied |
| Minimum riser height + tread length value set.
|
|
bool | riserPlusGoingMaxApplied |
| Maximum riser height + tread length value set.
|
|
bool | stairPitchMinApplied |
| Minimum stair pitch set.
|
|
bool | stairPitchMaxApplied |
| Maximum stair pitch set.
|
|
Represents a the Rules and Standards of a Stair element.