Archicad 27 C++ API
Loading...
Searching...
No Matches
API_StairTreadType Struct Reference

Represents a Tread element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
bool isCustom
 Tread is custom.
 
bool visible
 The object is visible.
 
API_StairTreadNosingTypeID nosingType
 Type of the Tread nosing: |APITN_ByValue|The Tread nosing is given a length value.| |APITN_BySlanting|The Tread nosing is given a slanting value.|.
 
double nosingValue
 Length of the nosing if the nosing type is by value.
 
double nosingSlant
 Slanting of the nosing if the nosing type is by slanting.
 
double offset
 Tread gap.
 
double thickness
 Tread thickness.
 
API_Guid owner
 GUID of the owning stair.
 
API_Guid libId
 Library part GUID.
 
UInt32 sequenceNumber
 The number of the step that the tread belongs to.
 
UInt32 subElemId
 The subelement identifier of the tread.
 
double zOffset
 The custom offset of the tread.
 
API_StairPartRoleID role
 Role of the Stair subelement.
 

Detailed Description

Represents a Tread element.

Member Data Documentation

◆ nosingType

API_StairTreadType::nosingType

Type of the Tread nosing: |APITN_ByValue|The Tread nosing is given a length value.| |APITN_BySlanting|The Tread nosing is given a slanting value.|.