Archicad 28 C++ API
Loading...
Searching...
No Matches
API_StoryType Struct Reference

Parameters of one story. More...

#include <APIdefs_Database.h>

Public Attributes

short index
 The story index. Should be between firstStory and lastStory in API_StoryInfo.
 
short floorId
 Unique ID of the story.
 
bool dispOnSections
 Story level lines should appear on sections and elevations.
 
double level
 The story level.
 
GS::uchar_t uName [API_UniLongNameLen]
 The name of the story as a Unicode string (UTF-16).
 

Detailed Description

Parameters of one story.

See also
API_StoryInfo
Remarks
Each parameter can be set in the "Story Settings..." dialog of Archicad are represented in the structure. The story height should be calculated based on neighboring stories. Refer to API_StoryInfo structure for further details.