Archicad 28 C++ API
Loading...
Searching...
No Matches
API_StoryInfo Struct Reference

Story information of the active project. More...

#include <APIdefs_Environment.h>

Public Attributes

short firstStory
 First story index.
 
short lastStory
 Last story index.
 
short actStory
 Actual (currently visible in 2D) story index.
 
bool skipNullFloor
 Floor indices above ground-floor level start with 1 instead of 0. (US, Japan)
 
API_StoryType ** data
 Array of data to hold the parameters of each story. Refer to API_StoryType for further details.
 
API_GhostStoryType ghostStory
 Ghost story settings. Refer to API_GhostStoryType for further details.
 

Detailed Description

Story information of the active project.

See also
ACAPI_ProjectSetting_GetStorySettings, ACAPI_ProjectSetting_ChangeStorySettings
Remarks
This structure corresponds to the "Story Settings..." dialog of Archicad. The parameters of each story are contained, as well as the parameters ghost story settings. Call the ACAPI_ProjectSetting_GetStorySettings or ACAPI_ProjectSetting_ChangeStorySettings functions to operate on this data. Remomber to dispose of the data array if you don't need it anymore. Note, that a virtual story is also exported, above the top story. This story does not exist, but the level parameter is important to calculate the height of the top story. Ghost story settings can also be retrieved by the ACAPI_View_GetGhostStorySettings function.