Archicad 27 C++ API
Loading...
Searching...
No Matches
API_GhostStoryType Struct Reference

Ghost Story settings. More...

#include <APIdefs_Environment.h>

Public Attributes

bool on
 Ghost story is visible or hidden.
 
bool showOne
 Ghost story is specified in the storyInd field (show this story)
 
bool showAbove
 Show on the story above the current as ghost story.
 
bool showBelow
 Show on the story below the current as ghost story.
 
short storyInd
 The index of the story displayed as ghost story (if showOne is true)
 
API_RGBColor ghostColor
 Ghost story color.
 
API_ElemFilter filter
 Element type filter to show/hide elements on the ghost story.
 

Detailed Description

Ghost Story settings.

See also
ACAPI_View_GetGhostStorySettings
Remarks
This structure is a member of API_StoryInfo.