Archicad 27 C++ API
Loading...
Searching...
No Matches
API_SubElement Struct Reference

Helper structure to create / modify / get markers for window, door, section, elevation, interior elevation, detail, worksheet elements and curtain wall parts. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Element subElem
 The sub element.
 
API_Element mask
 The sub element mask.
 
API_ElementMemo memo
 The memo of the sub element.
 
API_SubElementType subType
 The type of this sub element.
 
Int32 subIndex
 Used only for identify Interior Elevation, Curtain Wall, and Railing sub-segment by modification.
 
UInt32 subSubIndex
 Second-Level Subelement Index (Railing).
 
UInt32 subElemFlags
 Subelement Flags (Stair).
 

Detailed Description

Helper structure to create / modify / get markers for window, door, section, elevation, interior elevation, detail, worksheet elements and curtain wall parts.

Since
Archicad 25
Remarks
This structure reduces the number of parameters passed to ACAPI_Element_GetDefaultsExt, ACAPI_Element_ChangeDefaultsExt, ACAPI_Element_CreateExt, and ACAPI_Element_ChangeExt. This enumeration was renamed in Archicad 25, the previous name was API_SubElemMemoMask.