Archicad 28 C++ API
Loading...
Searching...
No Matches
API_SunInfo Struct Reference

Parameters of the sunlight. More...

#include <APIdefs_Environment.h>

Public Attributes

API_RGBColor sunRGB
 Color of the directional light.
 
API_RGBColor ambientRGB
 Color of the ambient light.
 
short sunIntensity
 Intensity of the directional light [0..100].
 
short ambientIntensity
 Intensity of the ambient light [0..100].
 
short sunToAmbient
 Contribution to ambient [0..100].
 

Detailed Description

Parameters of the sunlight.

Remarks
This structure is used when you get information about the sun. See the ACAPI_GeoLocation_GetSunSets environment function.