Archicad 28 C++ API
Loading...
Searching...
No Matches
API_TextFrameType Struct Reference

Parameters of the Text frame shape. More...

#include <APIdefs_Elements.h>

Public Attributes

API_TextFrameShapeTypeID shapeType
 Shape type identifier.
 
bool isSizeFixed
 Use fixed width and height values for the size of the shape polygon, otherwise the frame shape fits to the current text box.
 
double fixedWidth
 Width of the frame shape in mm, when isSizeFixed is true. Its value should be between 1 and 1000.
 
double fixedHeight
 Height of the frame shape in mm, when isSizeFixed is true. Its value should be between 1 and 1000.
This parameter is ignored in case of API_TextFrameShapeType_Circle shape type, where the value of fixedWidth is used as the diameter of the circle.
 

Detailed Description

Parameters of the Text frame shape.