Archicad 28 C++ API
|
Represents some text to measure its length. More...
#include <APIdefs_Goodies.h>
Public Attributes | |
short | index |
Line index. | |
bool | drvScaleCorr |
If true : scale the text to the model, if false : in mms. | |
bool | wantsLongestIndex |
If index is 0 -> true : return longest line's index, false : don't return longest line's index. | |
short | wFont |
Font attribute index. | |
short | wFace |
Style (face) of text: | |
double | wSlant |
Slant angle [radian] (PI/2 is plain text). | |
double | wSize |
Character height in mms. | |
char * | lineStr |
The text to measure. | |
GS::UniString * | lineUniStr |
Unicode text to measure. | |
Represents some text to measure its length.
API_TextLinePars::index |
Line index.
Value | Meaning |
---|---|
-1 | last line length |
0 | longest line length |
> 0 | length of the nth line |
API_TextLinePars::wFace |
Style (face) of text:
Face | Meaning |
---|---|
APIFace_Plain | Plain text |
APIFace_Bold | Bold |
APIFace_Italic | Italic |
APIFace_Underline | Underline |
APIFace_Outline | Outlined (Macintosh only) |
APIFace_Shadow | Shadow (Macintosh only) |