Archicad 28 C++ API
Loading...
Searching...
No Matches
API_UIStructureDisplay Struct Reference

This structure represents the Partial Structure Display state. More...

#include <APIdefs_Environment.h>

Public Attributes

API_StructureDisplay structureDisplay
 The Partial Structure Display state.
 
API_DatabaseUnId databaseUnId
 The identifier of the owner database.
 
bool is3D
 The owner is the 3D window.
 
bool filler [7]
 Reserved for later use.
 

Detailed Description

This structure represents the Partial Structure Display state.

Remarks
You are able to get and change the Partial Structure Display via ACAPI_Navigator_GetStructureDisplay and ACAPI_Navigator_ChangeStructureDisplay functions. This function allows you to display and output composite and complex elements in simplified form. All model based databases (Model2D, Model3D, Section, Elevation, InteriorElevation, DocumentFrom3D) contain their own Partial Structure Display state.