Archicad 28 C++ API
|
General representation of a Model Display in 3D Document. More...
#include <APIdefs_Environment.h>
Public Attributes | |
bool | shouldUseUniformCutAttributes |
Use uniform cut attributes. | |
short | uniformLineType |
Uniform line type index. | |
short | uniformFillPen |
Uniform fill index. | |
short | uniformFillBkgPen |
Background color of the uniform fill. | |
bool | shouldUseUncutSurfaceFill |
Use uncut surface fill. | |
API_3DCutSurfFills | fillCutSurfacesWith |
How to display the cut surfaces. | |
API_3DUncutSurfaceFillType | uncutSurfaceFillType |
How to display the uncut surfaces. | |
short | uncutSurfaceBkgPen |
Background color of the uncut surface. | |
bool | shouldUseElemPen |
Use elem pen. | |
short | elemPen |
Elem pen index. | |
short | shadFillPen |
Shadow fill pen. | |
API_AttributeIndex | shadFill |
Shadow fill index. | |
short | shadFillBkgPen |
Shadow fill background pen. | |
short | shadContPen |
Shadow contour pen. | |
API_3DHiddenEdgeVisibility | hiddenEdgeVisibility |
Show or hide hidden edges. | |
API_AttributeIndex | hiddenEdgeLineType |
Hidden edge line type. | |
short | hiddenEdgeLinePen |
Hidden edge line pen. | |
API_3DOnCutPlaneVisibility | onCutPlaneVisibility |
Show or hide hidden cut lines. | |
General representation of a Model Display in 3D Document.