Archicad 28 C++ API
|
A container that can store different types of data. More...
#include <APIdefs_Properties.h>
Public Attributes | |
API_VariantType | type |
Type of the data that the variant stores. | |
Int32 | intValue |
Integer value. | |
double | doubleValue |
Real value. | |
bool | boolValue |
Boolean value. | |
GS::UniString | uniStringValue |
String value. | |
API_Guid | guidValue |
GUID value. | |
A container that can store different types of data.
API_Variant::type |
Type of the data that the variant stores.
API_VariantType | Meaning |
---|---|
API_PropertyIntegerValueType | Variant with an integer value |
API_PropertyRealValueType | Variant with a real (double) value |
API_PropertyStringValueType | Variant with a string value |
API_PropertyBooleanValueType | Variant with a boolean value |
API_PropertyGuidValueType | Variant with a GUID value |