Archicad 27 C++ API
Loading...
Searching...
No Matches
API_VectType Struct Reference

Representation of a 3D normal vector. More...

#include <APIdefs_3D.h>

Public Attributes

API_3D_Head head
 Header information of this component. This specifies the type and database index.
 
double x
 The x coordinate of the point in the model space.
 
double y
 The y coordinate of the point in the model space.
 
double z
 The z coordinate of the point in the model space.
 

Detailed Description

Representation of a 3D normal vector.

Remarks
This structure is used to describe a normal vector of a polygon. If you get a polygon of a body, you will get an index (ivect field of API_PgonType structure) to an API_VectType structure. Use this index in the head.index field to get the normal vector of that polygon. Note: In the case of closed bodies, they point from the inside to the outside of the body. Normal vectors of an open body must point to the same side of the body.