Archicad 27 C++ API
Loading...
Searching...
No Matches
API_AttributePicker Class Referenceabstract

Describes an attribute picker created in ACAPI_Dialog_CreateAttributePicker, with getter and setter for the selected attribute and the hanlder of push check click event. More...

#include <APIdefs_Interface.h>

Public Member Functions

virtual API_AttributeIndex GetSelectedAttributeIndex () const =0
 Returns the index of the selected attribute.
 
virtual void SetSelectedAttributeIndex (const API_AttributeIndex &index)=0
 Sets the index of the attribute to select.
 
virtual bool Invoke ()=0
 Handles click event to the push check: shows the picker popup dialog.
 
virtual void Refresh ()=0
 Refreshes the dialogicon and the caption in the pushcheck.
 
virtual API_UserControlType GetUserControlType ()=0
 Returns the API_UserControlType param which was used to create itself.
 

Detailed Description

Describes an attribute picker created in ACAPI_Dialog_CreateAttributePicker, with getter and setter for the selected attribute and the hanlder of push check click event.

Since
Archicad 26

Member Function Documentation

◆ GetSelectedAttributeIndex()

virtual API_AttributeIndex API_AttributePicker::GetSelectedAttributeIndex ( ) const
pure virtual

Returns the index of the selected attribute.

Returns
the selected attribute's index

◆ SetSelectedAttributeIndex()

virtual void API_AttributePicker::SetSelectedAttributeIndex ( const API_AttributeIndex index)
pure virtual

Sets the index of the attribute to select.

Parameters
indexthe index of the attribute to select.