Archicad 28 C++ API
Loading...
Searching...
No Matches
IFCAPI::v1::Assignments Class Referencefinal

Represents the persistent Assignment Tree in IFC. More...

#include <IFCAssignments.hpp>

Inheritance diagram for IFCAPI::v1::Assignments:
ACAPI::v1::Object

Public Member Functions

std::unordered_set< IFCAPI::ObjectIDGetRootGroups () const
 Returns all root IFC groups.
 
std::unordered_map< IFCAPI::ObjectID, std::unordered_set< IFCAPI::ObjectID > > GetChildObjectTable () const
 Returns a table representing the nested child hierarchy.
 
std::unordered_map< IFCAPI::ObjectID, std::unordered_set< IFCAPI::ObjectID > > GetParentObjectTable () const
 Returns a table representing the parent hierarchy.
 
- Public Member Functions inherited from ACAPI::v1::Object
 Object (std::shared_ptr< Impl::ObjectImpl > impl)
 Constructs a new object.
 
const API_TokenGetToken () const
 Get the token for this object.
 

Friends

class ObjectAccessor
 

Additional Inherited Members

- Protected Member Functions inherited from ACAPI::v1::Object
 ~Object ()
 Default destructor.
 
- Protected Attributes inherited from ACAPI::v1::Object
std::shared_ptr< Impl::ObjectImplmImpl
 Impl object given by constructor.
 

Detailed Description

Represents the persistent Assignment Tree in IFC.

Since
Archicad 28
Remarks
Provides access the root IFC groups and a table of their nested child and parent hierarchy.