Archicad 27 C++ API
Loading...
Searching...
No Matches
Curtain Wall

Functions related to Curtain Wall manupulation and creation. More...

Classes

struct  API_CWContourData
 Represents a curtain wall contour type element. More...
 

Functions

GSErrCode __ACENV_CALL ACAPI_CurtainWall_IsCWPanelDegenerate (const API_Guid *guid, bool *isDegenerate)
 Checks whether the curtain wall panel is degenerate.
 
GSErrCode __ACENV_CALL ACAPI_CurtainWall_GetCWAbsoluteBottom (const API_Guid *guid, double *bottom)
 Retrieves the the base height of a curtain wall or its subelem.
 
GSErrCode __ACENV_CALL ACAPI_CurtainWall_GetCWHeight (const API_Guid *guid, double *height)
 Retrieves the height of a curtain wall element.
 
GSErrCode __ACENV_CALL ACAPI_CurtainWall_GetCWSubElemParams (const API_Guid *guid, API_AddParType ***params)
 Returns the calculated additional parameters of a curtain wall subelem.
 
GSErrCode __ACENV_CALL ACAPI_FreeCWContourPtr (API_CWContourData **contours)
 Frees the curtain wall contour pointer.
 

Detailed Description

Functions related to Curtain Wall manupulation and creation.

Function Documentation

◆ ACAPI_CurtainWall_GetCWAbsoluteBottom()

GSErrCode __ACENV_CALL ACAPI_CurtainWall_GetCWAbsoluteBottom ( const API_Guid guid,
double *  bottom 
)

Retrieves the the base height of a curtain wall or its subelem.

Parameters
guid[in] Curtain Wall or its subelem reference.
bottom[out] Bottom of the element. This value is relative to the element's home story.
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - guid or bottom parameter is nullptr.
  • APIERR_BADID - guid is invalid.
Remarks
This function is used to obtain the bottom of the curtain wall or its subelem (panel, fram, junction or accessory). As against the function name the bottom is relative to the element's home story.

◆ ACAPI_CurtainWall_GetCWHeight()

GSErrCode __ACENV_CALL ACAPI_CurtainWall_GetCWHeight ( const API_Guid guid,
double *  height 
)

Retrieves the height of a curtain wall element.

Parameters
guid[in] Curtain Wall reference.
height[out] Height of the curtain wall.
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - guid or height parameter is nullptr or the guid is invalid.
Remarks
This function is used to obtain the height - maximal difference of z coords - of the curtain wall.

◆ ACAPI_CurtainWall_GetCWSubElemParams()

GSErrCode __ACENV_CALL ACAPI_CurtainWall_GetCWSubElemParams ( const API_Guid guid,
API_AddParType ***  params 
)

Returns the calculated additional parameters of a curtain wall subelem.

Parameters
guid[in] Curtain Wall subelem reference.
params[out] Additional parameters of library part-based curtain wall subelem.
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - guid or params parameter is nullptr or the guid is invalid.
  • APIERR_BADID - The given element os not library part-based.
Remarks
This function is used to obtain the additional parameters of a library part-based curtain wall subelem (panel, frame, junction, accessory). Don't forget to call ACAPI_DisposeElemMemoHdls to dispose the params handle when you're done. This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

◆ ACAPI_CurtainWall_IsCWPanelDegenerate()

GSErrCode __ACENV_CALL ACAPI_CurtainWall_IsCWPanelDegenerate ( const API_Guid guid,
bool *  isDegenerate 
)

Checks whether the curtain wall panel is degenerate.

Parameters
guid[in] Curtain wall panel reference.
isDegenerate[out] Is the panel degenerate?
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - guid or height parameter is nullptr.
  • APIERR_BADID - guid is invalid or is not a curtain wall panel reference.
Remarks
Curtain Wall element may contain degenerate panel elements (eg. its length is Eps). These elements are not selectable but for technical reasons database must contains them. This function is used to filter these CW panels.

◆ ACAPI_FreeCWContourPtr()

GSErrCode __ACENV_CALL ACAPI_FreeCWContourPtr ( API_CWContourData **  contours)

Frees the curtain wall contour pointer.

Parameters
contours[in] A pointer to an array of API_CWContourData.
Returns
Remarks
This is the recommended way of disposing the curtain wall contour for compatibility reasons.