Archicad 27 C++ API
Loading...
Searching...
No Matches
Survey Points

Functions related to the Survey Point. More...

Functions

GSErrCode __ACENV_CALL ACAPI_SurveyPoint_GetSurveyPointTransformation (API_Tranmat *apiSPTransformation)
 Returns the transformation matrix that transforms points given in the Project Origin's coordinate system into the Survey Point's coordinate system.
 
GSErrCode __ACENV_CALL ACAPI_SurveyPoint_IsSurveyPointVisible (bool *spVisibility)
 Checks if the survey point is visible.
 
GSErrCode __ACENV_CALL ACAPI_SurveyPoint_SetSurveyPointVisibility (bool *spVisibility)
 Sets the visibility of the survey point.
 
GSErrCode __ACENV_CALL ACAPI_SurveyPoint_IsSurveyPointLocked (bool *isSurveyPointLocked)
 Returns the lock state of the Survey Point.
 
GSErrCode __ACENV_CALL ACAPI_SurveyPoint_SetSurveyPointLocked (bool *lockedState)
 Locks or Unlocks the Survey Point.
 

Detailed Description

Functions related to the Survey Point.

Function Documentation

◆ ACAPI_SurveyPoint_GetSurveyPointTransformation()

GSErrCode __ACENV_CALL ACAPI_SurveyPoint_GetSurveyPointTransformation ( API_Tranmat apiSPTransformation)

Returns the transformation matrix that transforms points given in the Project Origin's coordinate system into the Survey Point's coordinate system.

Since
Archicad 25
Parameters
apiSPTransformation[out] the calculated transformation matrix
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - apiSPTransformation is nullptr
Remarks
This function computes a transformation matrix that transforms the coordinates of a given point in the Project Origin's coordinate system into the Survey Point's coordinate system.
Example
if (ACAPI_Environment (APIEnv_GetSurveyPointTransformationID, &tm) == NoError) {
API_Coord3D pointInProject = { 1.0, 1.0, 0.0 };
API_Coord3D coordInSPSystem;
coordInSPSystem.x = tm.tmx[0]*pointInProject.x + tm.tmx[1]*pointInProject.y + tm.tmx[2]*pointInProject.z + tm.tmx[3];
coordInSPSystem.y = tm.tmx[4]*pointInProject.x + tm.tmx[5]*pointInProject.y + tm.tmx[6]*pointInProject.z + tm.tmx[7];
coordInSPSystem.z = tm.tmx[8]*pointInProject.x + tm.tmx[9]*pointInProject.y + tm.tmx[10]*pointInProject.z + tm.tmx[11];
ACAPI_WriteReport ("Point coordinates in the Survey Point's coordinate system: x=%lf, y=%lf, z=%lf",
false, coordInSPSystem.x, coordInSPSystem.y, coordInSPSystem.z);
}
void __ACENV_CALL ACAPI_WriteReport(const GS::UniString &format, bool withDial,...)
Writes a report string into the Report Windowot into a custom alert window.
Real (Cartesian) 3D coordinates of a three-dimensional space.
Definition: APIdefs_Base.h:100
double x
The x factor.
Definition: APIdefs_Base.h:104
double z
The z factor.
Definition: APIdefs_Base.h:114
double y
The y factor.
Definition: APIdefs_Base.h:109
A 3*4 transformation matrix.
Definition: APIdefs_Base.h:320

◆ ACAPI_SurveyPoint_IsSurveyPointLocked()

GSErrCode __ACENV_CALL ACAPI_SurveyPoint_IsSurveyPointLocked ( bool *  isSurveyPointLocked)

Returns the lock state of the Survey Point.

Since
Archicad 25
Parameters
isSurveyPointLocked[out] Lock state of the Survey Point
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - The passed parameter is nullptr
Remarks
The Survey Point can be locked in order to prevent its floor plan position coordinates and the project north angle from being changed.
Example
bool isSurveyPointLocked = false;
ACAPI_Environment (APIEnv_IsSurveyPointLockedID, &isSurveyPointLocked);

◆ ACAPI_SurveyPoint_IsSurveyPointVisible()

GSErrCode __ACENV_CALL ACAPI_SurveyPoint_IsSurveyPointVisible ( bool *  spVisibility)

Checks if the survey point is visible.

Since
Archicad 25
Parameters
spVisibility[out] Survey point visibility
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - spVisibility is nullptr
Remarks
This function checks the visibility of the survey point.
Example
bool spVisibility = true;
ACAPI_Environment (APIEnv_IsSurveyPointVisibleID, &spVisibility);

◆ ACAPI_SurveyPoint_SetSurveyPointLocked()

GSErrCode __ACENV_CALL ACAPI_SurveyPoint_SetSurveyPointLocked ( bool *  lockedState)

Locks or Unlocks the Survey Point.

Since
Archicad 25
Parameters
lockedState[in] Lock state of the Survey Point
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - The passed parameter is nullptr
Remarks
This function locks or unlocks the Survey Point. Note that this lock affects only the North Angle and the floor plan position of the Survey Point. All the other parameters of the API_GeoLocation data can be changed even if the Survey Point is locked.
Example
bool lockedState = true;
ACAPI_Environment (APIEnv_SetSurveyPointLockedID, &lockedState);

◆ ACAPI_SurveyPoint_SetSurveyPointVisibility()

GSErrCode __ACENV_CALL ACAPI_SurveyPoint_SetSurveyPointVisibility ( bool *  spVisibility)

Sets the visibility of the survey point.

Since
Archicad 25
Parameters
spVisibility[in] New survey point visibility
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - spVisibility is nullptr
Remarks
This function sets the visibility of the survey point.
Example
bool spVisibility = true;
ACAPI_Environment (APIEnv_SetSurveyPointVisibilityID, &spVisibility);