Archicad 28 C++ API
Loading...
Searching...
No Matches
API_3DProjectionInfo Struct Reference

3D projection setting parameters. More...

#include <APIdefs_Environment.h>

Public Attributes

bool isPersp
 Perspective or parallel projection settings.
 
API_Guid camGuid
 Guid of the camera; if specified from a floorplan camera element.
 
API_Guid actCamSet
 Guid of the camera set; if specified from a floorplan camera element.
 
union { 
 
   API_PerspPars   persp 
 Perspective settings.
 
   API_AxonoPars   axono 
 Parallel projection settings.
 
u 
 Perspective or parallel project settings.
 

Detailed Description

3D projection setting parameters.

Remarks
This structure corresponds to the "3D Projection Settings..." dialog of Archicad. The isPersp field determines whether perspective or a parallel view is set. Refer to the API_PerspPars or API_AxonoPars structures to get the right projection parameters, respectively. Refer to the ACAPI_View_Get3DProjectionSets and ACAPI_View_Change3DProjectionSets functions to get the current settings.