Archicad 27 C++ API
Loading...
Searching...
No Matches
API_PerspPars Struct Reference

Perspective projection parameters. More...

#include <APIdefs_Elements.h>

Public Attributes

double azimuth
 rotation angle of the camera around the target
 
API_SunAngleSettings sunAngSets
 Sun's angle settings.
 
double viewCone
 angle of the camera view cone
 
double rollAngle
 roll angle of the camera
 
double distance
 distance of the camera and the target
 
double cameraZ
 Z coordinate of camera position.
 
double targetZ
 Z coordinate of target position.
 
bool isTwoPointPersp
 Two-point perspective mode.
 
API_Coord pos
 X and Y coordinate of camera position.
 
API_Coord target
 X and Y coordinate of target position.
 

Detailed Description

Perspective projection parameters.

Remarks
This structure corresponds to parameters set in the "3D Projection Settings..." dialog of Archicad, when a perspective view is selected. Refer to the ACAPI_View_Get3DProjectionSets function to get the actual projection parameters.