Archicad 28 C++ API
Loading...
Searching...
No Matches
API_AxonoPars Struct Reference

Parallel projection parameters. More...

#include <APIdefs_Elements.h>

Public Attributes

double azimuth
 rotation angle of the camera around the target
 
API_SunAngleSettings sunAngSets
 Sun's angle settings.
 
short projMod
 projection type selected
 
API_Tranmat tranmat
 the transformation matrix to calculate projected coordinates
 
API_Tranmat invtranmat
 the inverse transformation matrix to calculate model coordinates from projected ones
 

Detailed Description

Parallel projection parameters.

Remarks
This structure corresponds to parameters set in the "3D Projection Settings..." dialog of Archicad, when a parallel view is selected. Refer to the ACAPI_View_Get3DProjectionSets function to get the actual projection parameters.