Archicad 28 C++ API
Loading...
Searching...
No Matches
API_ActTranPars Struct Reference

Structure for retrieving the transformation data of the actual editing operation. More...

#include <APIdefs_Elements.h>

Public Attributes

API_EditCmdID typeID
 Type of the editing operation.
 
bool topNodeStretched
 For vertical stretch editing, identifies the base the vertical displacement to be added to.
 
API_Vector theDisp
 Displacement vector on the x-y plane.
 
API_Vector theAxeVect
 Unit vector for mirroring (the base point of the mirror axis is stored in theOrigo)
 
API_Coord theOrigo
 Base coordinate for Rotate, Mirror, Stretch and Resize operations.
 
double theCosA
 Cosine of the rotation angle.
 
double theSinA
 Sine of the rotation angle.
 
double theDispZ
 Vertical displacement for Elevate and VertStretch operations.
 
double theRatio
 Ratio for the Resize operation.
 
API_Vector sectionLineDir
 Cutplane line direction unit vector.
 

Detailed Description

Structure for retrieving the transformation data of the actual editing operation.

Remarks
For the utilization of this structure see the ACAPI_Notification_GetTranParams function.