Archicad 28 C++ API
|
Describes or references an Structural Analytical Model Cross Section for Curve Members. More...
#include <APIdefs_AnalyticalModel.h>
Public Attributes | |
API_AnalyticalCrossSectionType | crossSectionType |
The type of the Structural Analytical Model Cross Section (simple, custom, or predefined). | |
double | width |
The width of the profile. | |
double | height |
The height of the profile. | |
double | veneerThickness |
The thickness of core-type veneer in case of simple type. | |
API_AttributeIndex | profileAttrIndex |
The attribute index in case of predefined type. | |
GS::Array< API_AttributeIndex > | materialAttrIndices |
The attribute indices of the profile (see the Remarks below). | |
GS::HashTable< API_Guid, double > | profileParameters |
Contains the GUID of the profile modifiers and the parameter values. | |
GS::Optional< ProfileVectorImage > | profileImage |
Contains the ProfileVectorImage of the profile if it is an Attribute Profile, or Custom Profile. | |
API_AnalyticalAlignmentType | alignment = API_AnalyticalAlignmentType::None |
Describes the alignment of a Cross Section. | |
Describes or references an Structural Analytical Model Cross Section for Curve Members.
width
and height
represent the circle diameter. In the case of simple type profiles with no/finish/other veneers, it contains the attribute index of the core material. Simple type profiles with core veneer contain the attribute index of the veneer's material on the first position, and the core's on the second. In predefined type profiles, it contains as many attribute indices as the profile's materials.