Archicad 27 C++ API
Loading...
Searching...
No Matches
API_AnalyticalCurve Struct Reference

Describes an Structural Analytical Model Curve that is either a line segment between two Structural Analytical Model Nodes, or an arc segment with a specified intermediate point. More...

#include <APIdefs_AnalyticalElements.h>

Public Attributes

API_AnalyticalCurveType type
 The type of the Structural Analytical Model Curve.
 
API_AnalyticalNode begNode
 The beginning Node of the Structural Analytical Model Curve.
 
API_AnalyticalNode endNode
 The ending Node of the Structural Analytical Model Curve.
 
GS::Array< API_Coord3DmidCoords
 The intermediate point coordinates in case of arc or multi point segments.
 

Detailed Description

Describes an Structural Analytical Model Curve that is either a line segment between two Structural Analytical Model Nodes, or an arc segment with a specified intermediate point.

Since
Archicad 25
Remarks
The midCoords member holds valid data only in case of arc or multi point segments. It's content is undefined for line segments.