Archicad 28 C++ API
|
Describes the Structural Analytical Model Analytical Edge Load settings. More...
#include <APIdefs_AnalyticalElements.h>
Public Attributes | |
API_Guid | loadCaseId |
The guid of the connected Load Case. | |
API_AnalyticalLoad_LoadForceType | loadForceType |
The force type of the Analytical Edge Load. The edge force can be defined in three main directions (global or local coordinate system). An edge of the structure may be subject to a moment load. The load is defined by the direction and size of the moment. | |
API_AnalyticalLoad_LoadDistributionType | loadDistributionType |
The load may be either constant along the 1D member or linearly variable (trapezoidal). | |
API_AnalyticalCoordSysDirection | coordinateSystemType |
Defines the co-ordinate system of the member in which the load is applied. For " Local", coordinate system is defined by the member where is load applied. | |
API_Vector3D | startValue |
The start force/moment value of the Analytical Edge Load in the X, Y and Z directions. | |
API_Vector3D | endValue |
The end force/moment value of the Analytical Edge Load in the X, Y and Z directions. | |
Describes the Structural Analytical Model Analytical Edge Load settings.