Archicad 28 C++ API
|
Describes a Structural Analytical Model Varying Segment for Curve Members. More...
#include <APIdefs_AnalyticalModel.h>
Public Attributes | |
API_AnalyticalCrossSection | begProfile |
The begin profile of the segment. If the segment is not tapered, this is also the end profile. | |
GS::Optional< API_AnalyticalCrossSection > | endProfile |
If the segment is tapared, this describes the end profile of the segment. | |
double | span = 0.0 |
The span of the Varying Segment. It should be between 0 and 1. | |
Describes a Structural Analytical Model Varying Segment for Curve Members.