Archicad 28 C++ API
|
Represents an general segment. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_ModelElemStructureType | modelElemStructureType |
The structure type of the column's segment. | |
API_AttributeIndex | buildingMaterial |
Building Material index of column's hatch. Used only, if structure type is API_BasicStrucure . | |
bool | circleBased |
Defines whether the column is circular (true) or rectangular/profiled (false). | |
API_AttributeIndex | profileAttr |
Attribute index of the extruded profile. | |
short | profileType |
The type of the profile: | |
bool | isHomogeneous |
Whether it is homogeneous which means the size of the segment's profiles are the same at the beginning and end of it. | |
double | nominalWidth |
Nominal width of segment. | |
double | nominalHeight |
Nominal height of segment. | |
bool | isWidthAndHeightLinked |
State of linking between width and height. | |
double | endWidth |
Width of end in case of not homogeneous uniformity. | |
double | endHeight |
Height of end in case of not homogeneous uniformity. | |
bool | isEndWidthAndHeightLinked |
State of linking between end width and end height in case of not homogeneous uniformity. | |
double | relativeHomeStoryLevel |
Relative Home Story Level of the segment, should not be interpreted on default, only on instance. Output only parameter. | |
Represents an general segment.