Archicad 27 C++ API
Loading...
Searching...
No Matches
API_BeamPart Struct Reference

Section of a beam that crosses the room. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Guid guid
 GUID of the beam.
 
Int32 filler [2]
 
double tBeg
 Beginning distance of the section from the beginning point of the beam.
 
double tEnd
 End distance of the section from the beginning point of the beam.
 

Detailed Description

Section of a beam that crosses the room.

Remarks
The API_BeamPart structure is a member of API_RoomRelation. The following example shows how to interpret this data.
Room beam part
@ref API_RoomRelation
| nBeamPart | | 2 | | beamPart[0] | | | | | tBeg | 0.00 | | | tEnd | 2.05 | | beamPart[1] | | | | tBeg | 0.30 | | | tEnd | 4.00 |