Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RoomRelation Struct Reference

Structure for retrieving data related to a room. More...

#include <APIdefs_Elements.h>

Public Attributes

GS::HashTable< API_ElemType, GS::Array< API_Guid > > elementsGroupedByType
 Related elements of the room grouped by type. The keys in this table are the types and the values are the GUIDs of the elements with the given type.
 
GS::Array< API_WallPartwallPart
 Wall parts that borders the room polygon.
 
GS::Array< API_BeamPartbeamPart
 Beam parts that related to the room.
 
GS::Array< API_CWSegmentPartcwSegmentPart
 Curtain Wall Segment parts that related to the room.
 
GS::Array< API_Nicheniches
 Niches inside the room.
 

Detailed Description

Structure for retrieving data related to a room.

Since
Archicad 26
Remarks
Get the array's size with it's GetSize() function. To learn more about the usage of the room relation structure please refer to the ACAPI_Element_GetRelations function. From version 26 the type of the elementsGroupedByType member was changed into GS::HashTable< API_ElemType, GS::Array<API_Guid>>.