Archicad 27 C++ API
Loading...
Searching...
No Matches
API_WallPart Struct Reference

Section of a wall segment that neighbours a border line of the room. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Guid guid
 Guid of the wall.
 
Int32 roomEdge
 Index of the room polygon edge adjacent to the wall.
 
Int32 filler
 
double tBeg
 Beginning distance of the section from the beginning point of the wall.
 
double tEnd
 End distance of the section from the beginning point of the wall.
 

Detailed Description

Section of a wall segment that neighbours a border line of the room.

See also
API_CWSegmentPart
Remarks
The API_WallPart structure is a member of API_RoomRelation. The following example shows how to interpret this data.
Room wall part