Archicad 27 C++ API
Loading...
Searching...
No Matches
API_Niche Struct Reference

Structure describing a niche in a room. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Coord ** coords
 Coordinate array.
 
Int32 ** pends
 Polygon endpoints; see API_Polygon for more information.
 
API_PolyArc ** parcs
 Polygon arcs; see API_PolyArc and API_Polygon for more information.
 
double height
 Height of the niche.
 

Detailed Description

Structure describing a niche in a room.

Remarks
The API_Niche structure is a member of API_RoomRelation. If you need to add niches to area or volume calculation of a room, get the room relations with the ACAPI_Element_GetRelations function.