Archicad 27 C++ API
Loading...
Searching...
No Matches
API_CWFrameQuantity Struct Reference

Describes the different calculated values for curtain wall frames. More...

#include <APIdefs_Elements.h>

Public Attributes

GS::uchar_t typeText [API_UniLongNameLen]
 Name of the GDL object.
 
GS::uchar_t categoryText [API_UniLongNameLen]
 Category of the frame in textual form. See API_CWFrameCategory for possible values.
 
double direction
 Direction of the frame.
 
double width
 Width of the frame.
 
double depth
 Depth of the frame.
 
double length
 Length of the frame.
 
API_AttributeIndex material
 Material index of the frame.
 
short position
 Physical position of the frame. See API_CWFrameCategory for possible values.
 

Detailed Description

Describes the different calculated values for curtain wall frames.

Remarks
See also the curtain wall frame parameters for listing in Appendix A of the GDL Reference manual.